summaryrefslogtreecommitdiffstats
path: root/openpgp/Cargo.toml
diff options
context:
space:
mode:
authorWiktor Kwapisiewicz <wiktor@metacode.biz>2022-10-03 11:51:41 +0200
committerWiktor Kwapisiewicz <wiktor@metacode.biz>2022-12-22 12:46:08 +0100
commit0d0d757f90b8b49010f998435a7e295cc0719ed2 (patch)
treee064d21b27c08b7e3371a5e51e30ba92da999381 /openpgp/Cargo.toml
parent31564c1c6e5b5ff4ff3596bb755ba2f7395f83df (diff)
openpgp: Add OpenSSL cryptographic backend.
- Adds the backend behind `crypto-openssl` feature. - Add CI configuration to run tests with the new backend. - See #333.
Diffstat (limited to 'openpgp/Cargo.toml')
-rw-r--r--openpgp/Cargo.toml8
1 files changed, 8 insertions, 0 deletions
diff --git a/openpgp/Cargo.toml b/openpgp/Cargo.toml
index a58a2027..a6f6b308 100644
--- a/openpgp/Cargo.toml
+++ b/openpgp/Cargo.toml
@@ -44,6 +44,13 @@ regex-syntax = "0.6"
sha1collisiondetection = { version = "0.2.3", default-features = false, features = ["std"] }
thiserror = "1.0.2"
xxhash-rust = { version = "0.8", features = ["xxh3"] }
+# At least 0.10.45 is needed due to CipherCtx::cipher_final_unchecked
+openssl = { version = ">= 0.10.45", optional = true }
+# We need to directly depend on the sys crate so that the metadata produced
+# in its build script is passed to sequoia-openpgp's build script
+# see: https://doc.rust-lang.org/cargo/reference/build-scripts.html#the-links-manifest-key
+openssl-sys = { version = ">= 0.9.80", optional = true }
+foreign-types-shared = { version = "0.1.1", optional = true }
# RustCrypto crates.
aes = { version = "0.6.0", optional = true }
@@ -101,6 +108,7 @@ crypto-rust = [
"rand_core", "rand_core/getrandom", "ecdsa"
]
crypto-cng = ["eax", "winapi", "win-crypto-ng", "ed25519-dalek", "num-bigint-dig"]
+crypto-openssl = ["openssl", "openssl-sys", "foreign-types-shared"]
# Experimental and variable-time cryptographic backends opt-ins
allow-experimental-crypto = []