summaryrefslogtreecommitdiffstats
path: root/openpgp/Cargo.toml
diff options
context:
space:
mode:
authorIgor Matuszewski <igor@sequoia-pgp.org>2020-10-15 17:28:53 +0200
committerIgor Matuszewski <igor@sequoia-pgp.org>2020-10-18 23:06:02 +0200
commitd98d9db3a57da2f8ee5cb28722bd1535d7387e55 (patch)
tree64521421f8e88a2747c6c907d6cdf591fcda00ab /openpgp/Cargo.toml
parente2fbf5b9d442f156ee433a3e46c98ec3dc89cc61 (diff)
openpgp: Implement date formatting for WASM using chrono crate
Diffstat (limited to 'openpgp/Cargo.toml')
-rw-r--r--openpgp/Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/openpgp/Cargo.toml b/openpgp/Cargo.toml
index 40f87247..67240aaa 100644
--- a/openpgp/Cargo.toml
+++ b/openpgp/Cargo.toml
@@ -49,6 +49,9 @@ num-bigint-dig = { version = "0.6", default-features = false, optional = true }
ed25519-dalek = { version = "1", default-features = false, features = ["rand", "u64_backend"], optional = true }
winapi = { version = "0.3", default-features = false, features = ["bcrypt"], optional = true }
+[target.'cfg(all(target_arch = "wasm32", target_os = "unknown"))'.dependencies]
+chrono = { version = "0.4", default-features = false, features = ["std"] }
+
[build-dependencies]
lalrpop = "0.19"