summaryrefslogtreecommitdiffstats
path: root/openpgp/Cargo.toml
diff options
context:
space:
mode:
authorKai Michaelis <kai@sequoia-pgp.org>2018-04-23 18:29:30 +0200
committerKai Michaelis <kai@sequoia-pgp.org>2018-04-23 18:32:22 +0200
commitd1345c3ffbf460f3007f063a989c795cdb50318b (patch)
tree2fedaabe45e4bf1c4e384aeeb2b65509dcd3d258 /openpgp/Cargo.toml
parentd6918cb480869e8ef911cf57dec63edbacf2ca94 (diff)
openpgp: Enums for various alogrithms
Adds enums for cryptographic and compression algorithms. Functions that operate on algo identifiers are now member functions (hash_context -> HashAlgo::context()). The identifiers support convertions from and to u8 as well as Display.
Diffstat (limited to 'openpgp/Cargo.toml')
-rw-r--r--openpgp/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/openpgp/Cargo.toml b/openpgp/Cargo.toml
index 31ceabd8..d117c0d7 100644
--- a/openpgp/Cargo.toml
+++ b/openpgp/Cargo.toml
@@ -11,6 +11,7 @@ failure = "0.1.1"
flate2 = "1.0.1"
nettle = { git = "https://gitlab.com/sequoia-pgp/nettle-rs.git" }
num-derive = "0.1.41"
+quickcheck = "0.6"
[dependencies.num]
version = "0.1.40"