summaryrefslogtreecommitdiffstats
path: root/openpgp/Cargo.toml
diff options
context:
space:
mode:
authorHeiko Schaefer <heiko@schaefer.name>2022-12-12 10:27:38 +0100
committerNeal H. Walfield <neal@pep.foundation>2022-12-13 15:35:23 +0100
commit8df445e5be29e80010fbc1e5460f3a2c3d57fb4f (patch)
treeb2984803d911951927ad5220cc508d071cdb6ecc /openpgp/Cargo.toml
parenta7ea4824783846b0ff9eea8d5409f049c7abdf03 (diff)
openpgp: Fix dependency on base64.
- Version 0.20 of `base64` introduces breaking changes to parts of the API that `sequoia-openpgp` uses. - Limit sequoia-openpgp's use of the `base64` crate to versions 0.12 up to, but not including, 0.20. (The `sequoia-autocrypt` and `sequoia-net` crates work with the `base64` 0.20 API, so their dependency on `base64` is not limited.) - Fixes #961.
Diffstat (limited to 'openpgp/Cargo.toml')
-rw-r--r--openpgp/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/openpgp/Cargo.toml b/openpgp/Cargo.toml
index ba65f97a..c95918aa 100644
--- a/openpgp/Cargo.toml
+++ b/openpgp/Cargo.toml
@@ -29,7 +29,7 @@ maintenance = { status = "actively-developed" }
[dependencies]
anyhow = "1.0.18"
buffered-reader = { path = "../buffered-reader", version = "1.0.0", default-features = false }
-base64 = ">=0.12"
+base64 = ">=0.12, <0.20"
bzip2 = { version = "0.4", optional = true }
dyn-clone = "1"
flate2 = { version = "1.0.1", optional = true }