summaryrefslogtreecommitdiffstats
path: root/openpgp/Cargo.toml
diff options
context:
space:
mode:
authorNeal H. Walfield <neal@pep.foundation>2018-01-14 21:40:57 +0100
committerNeal H. Walfield <neal@pep.foundation>2018-01-14 21:59:53 +0100
commit5d69d7b36830c2a43a05b4527998f860afd2aa4d (patch)
tree6804beb1f2bf5f3cfcb9aacbf966edf02c8ca4fa /openpgp/Cargo.toml
parent7a88168b1869e3b8b19c9349ecd0f0adc4f112c6 (diff)
openpgp: Implement hashing.
- Switch to using nettle for low-level hash functionality. - Add functionality for hasing UserID, UserAttribute, Key and Signature packets. - Add functionliaty to compute the hashes for primary key bindings, subkey bindings, user id bindings and user attribute bindings.
Diffstat (limited to 'openpgp/Cargo.toml')
-rw-r--r--openpgp/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/openpgp/Cargo.toml b/openpgp/Cargo.toml
index 6a5ad7a7..9e41958f 100644
--- a/openpgp/Cargo.toml
+++ b/openpgp/Cargo.toml
@@ -8,6 +8,6 @@ buffered-reader = { path = "../buffered-reader" }
base64 = "0.8.0"
bzip2 = "0.3.2"
flate2 = "0.2"
+nettle = { git = "https://gitlab.com/sequoia-pgp/nettle-rs.git" }
num = "0.1.40"
num-derive = "0.1.41"
-sha1 = "*"