summaryrefslogtreecommitdiffstats
path: root/openpgp/Cargo.toml
diff options
context:
space:
mode:
authorJustus Winter <justus@sequoia-pgp.org>2021-09-20 15:19:55 +0200
committerJustus Winter <justus@sequoia-pgp.org>2021-10-05 11:46:38 +0200
commit4eb79a5dd7c1bc39ba568828f4510c5893088f74 (patch)
treedaa901c8507c4f803df66a3719a6b0dea9c63888 /openpgp/Cargo.toml
parent341fdd29a9863e793c560e2a7207989c4f61d772 (diff)
openpgp: Implement ECDH and ECDSA over NistP256 with RustCrypto.
Diffstat (limited to 'openpgp/Cargo.toml')
-rw-r--r--openpgp/Cargo.toml6
1 files changed, 5 insertions, 1 deletions
diff --git a/openpgp/Cargo.toml b/openpgp/Cargo.toml
index cd285ebe..4f7389d3 100644
--- a/openpgp/Cargo.toml
+++ b/openpgp/Cargo.toml
@@ -55,12 +55,15 @@ cipher = { version = "0.2.5", optional = true, features = ["std"] }
des = { version = "0.6.0", optional = true }
digest = { version = "0.9.0", optional = true }
eax = { version = "0.3.0", optional = true }
+ecdsa = { version = "0.11", optional = true, features = ["hazmat", "arithmetic"] } # XXX
ed25519-dalek = { version = "1", default-features = false, features = ["rand", "u64_backend"], optional = true }
generic-array = { version = "0.14.4", optional = true }
idea = { version = "0.3.0", optional = true }
md-5 = { version = "0.9.1", optional = true }
num-bigint-dig = { version = "0.6", default-features = false, optional = true }
+p256 = { version = "0.8", optional = true, features = ["ecdh", "ecdsa"] }
rand = { version = "0.7.3", optional = true }
+rand_core = { version = "0.6", optional = true }
ripemd160 = { version = "0.9.1", optional = true }
rsa = { version = "0.3.0", optional = true }
sha-1 = { version = "0.9.2", optional = true }
@@ -92,7 +95,8 @@ crypto-nettle = ["nettle"]
crypto-rust = [
"aes", "block-modes", "block-padding", "blowfish", "cast5", "cipher", "des",
"digest", "eax", "ed25519-dalek", "generic-array", "idea", "md-5", "num-bigint-dig", "rand",
- "ripemd160", "rsa", "sha-1", "sha2", "twofish", "typenum", "x25519-dalek"
+ "ripemd160", "rsa", "sha-1", "sha2", "twofish", "typenum", "x25519-dalek", "p256",
+ "rand_core", "rand_core/getrandom", "ecdsa"
]
crypto-cng = ["eax", "winapi", "win-crypto-ng", "ed25519-dalek", "num-bigint-dig"]