summaryrefslogtreecommitdiffstats
path: root/openpgp/Cargo.toml
diff options
context:
space:
mode:
authorJustus Winter <justus@sequoia-pgp.org>2020-11-27 15:30:06 +0100
committerJustus Winter <justus@sequoia-pgp.org>2020-11-27 15:31:51 +0100
commit2def442c97f007f912395588c6d0bad016597e17 (patch)
treefadca7206f1326448ce3abc017db6360e281f191 /openpgp/Cargo.toml
parentfb1cbfb34ad0a895c449a9bcdcf9c8f5e9298fd9 (diff)
openpgp: Drop dependency on the digest crate.
Diffstat (limited to 'openpgp/Cargo.toml')
-rw-r--r--openpgp/Cargo.toml3
1 files changed, 1 insertions, 2 deletions
diff --git a/openpgp/Cargo.toml b/openpgp/Cargo.toml
index 41f7e955..c7182007 100644
--- a/openpgp/Cargo.toml
+++ b/openpgp/Cargo.toml
@@ -29,7 +29,6 @@ anyhow = "1"
buffered-reader = { path = "../buffered-reader", version = "0.20", default-features = false }
base64 = "0.13"
bzip2 = { version = "0.4", optional = true }
-digest = "0.9"
dyn-clone = "1"
flate2 = { version = "1.0.1", optional = true }
idna = "0.2"
@@ -39,7 +38,7 @@ libc = "0.2"
memsec = { version = "0.6", default-features = false }
nettle = { version = "7", optional = true }
regex = "1"
-sha1collisiondetection = "0.1"
+sha1collisiondetection = { version = "0.2", default-features = false, features = ["std"] }
thiserror = "1"
backtrace = "0.3.46"
unicode-normalization = "0.1.9"