summaryrefslogtreecommitdiffstats
path: root/openpgp/Cargo.toml
diff options
context:
space:
mode:
authorNora Widdecke <nora@sequoia-pgp.org>2020-03-27 12:47:58 +0100
committerNora Widdecke <nora@sequoia-pgp.org>2021-04-13 12:38:15 +0200
commit1e6c4d8e4aeac6d8673ca2b768d7243940e70d13 (patch)
treef9552f4aa1b5d4a96698f1ba8d0ef53dd37aa98e /openpgp/Cargo.toml
parent7293e6e9b01e255dc1adde9b7aa8b5666132cbdc (diff)
bench: Add benchmarks for parsing keys.
- Generate a flooded cert before the benchmark is run.
Diffstat (limited to 'openpgp/Cargo.toml')
-rw-r--r--openpgp/Cargo.toml5
1 files changed, 5 insertions, 0 deletions
diff --git a/openpgp/Cargo.toml b/openpgp/Cargo.toml
index 85cb1414..5dda0492 100644
--- a/openpgp/Cargo.toml
+++ b/openpgp/Cargo.toml
@@ -61,6 +61,7 @@ lalrpop = ">=0.17"
quickcheck = { version = "0.9", default-features = false }
rand = { version = "0.7", default-features = false }
rpassword = "5.0"
+criterion = { version = "0.3.4", features = ["html_reports"] }
[features]
default = ["compression", "crypto-nettle"]
@@ -83,3 +84,7 @@ bench = false
[[example]]
name = "pad"
required-features = ["compression-deflate"]
+
+[[bench]]
+name = "parse_cert"
+harness = false