summaryrefslogtreecommitdiffstats
path: root/openpgp/Cargo.toml
diff options
context:
space:
mode:
authorNora Widdecke <nora@sequoia-pgp.org>2021-02-10 14:49:33 +0100
committerNora Widdecke <nora@sequoia-pgp.org>2021-04-13 12:38:16 +0200
commit0055f6ba67161692d2a5d32b8c00c6b32bf0c0f1 (patch)
tree3cfe5110dd32cc6350c07d2ecb6303cdf8c2e922 /openpgp/Cargo.toml
parenta931158a9810d1ab37a48640c38da779eca6113f (diff)
bench: Restructure.
- Move all benchmarks into a single binary. This prevents dead_code warnings for common functions not used in a specific benchmark, and makes adding new benchmarks a little less surprising. - Cargo would autimatically try to compile all .rs files in /benches as benchmarks. Prevent this with `autobenches = false`.
Diffstat (limited to 'openpgp/Cargo.toml')
-rw-r--r--openpgp/Cargo.toml31
1 files changed, 2 insertions, 29 deletions
diff --git a/openpgp/Cargo.toml b/openpgp/Cargo.toml
index 258f5b2e..a520645b 100644
--- a/openpgp/Cargo.toml
+++ b/openpgp/Cargo.toml
@@ -12,6 +12,7 @@ authors = [
]
build = "build.rs"
documentation = "https://docs.rs/sequoia-openpgp"
+autobenches = false
homepage = "https://sequoia-pgp.org/"
repository = "https://gitlab.com/sequoia-pgp/sequoia"
readme = "README.md"
@@ -86,33 +87,5 @@ name = "pad"
required-features = ["compression-deflate"]
[[bench]]
-name = "generate_cert"
-harness = false
-
-[[bench]]
-name = "parse_cert"
-harness = false
-
-[[bench]]
-name = "encrypt_message"
-harness = false
-
-[[bench]]
-name = "decrypt_message"
-harness = false
-
-[[bench]]
-name = "encrypt_sign_message"
-harness = false
-
-[[bench]]
-name = "decrypt_verify_message"
-harness = false
-
-[[bench]]
-name = "sign_message"
-harness = false
-
-[[bench]]
-name = "verify_message"
+name = "run_benchmarks"
harness = false