summaryrefslogtreecommitdiffstats
path: root/openpgp-ffi/Cargo.toml
diff options
context:
space:
mode:
authorNora Widdecke <nora@sequoia-pgp.org>2020-12-10 11:04:09 +0100
committerNora Widdecke <nora@sequoia-pgp.org>2020-12-10 17:08:07 +0100
commit386b3bc3bbaf7a7abaaa2c2587b0510c161cb67a (patch)
treeefd59162fef5a8583690b8ad9844f988d18c8471 /openpgp-ffi/Cargo.toml
parente9439f7c4b902265d3f599c224e5e5ac9798014e (diff)
Correct minimal versions.
- Versions required by feature or API usage: - anyhow 1.0.5. - We use `impl From<anyhow::Error> for Box<dyn std::error::Error + Send + Sync + 'static>`, introduced in 1.0.5. - tokio 0.2.19 - We use `tokio::net::tcp::OwnedReadHalf`, introduced in 0.2.19. - chrono 0.4.10 - We use the `std` feature, introduced in 0.4.10. - thiserror 1.0.2 - futures and futures-util 0.3.5 - tempfile 3.1 - c_doctests require the same version of rand both as direct dependency and through tempfile. - Yanked versions: - structopt 0.3.11. 0.3.8 to 0.3.10 were yanked. - socket2 0.3.16. 0.3.0 to 0.3.15 were yanked. - Update our dependencies to the package versions required by other dependencies, e.g. structopt requires lazy_static 1.4.0. - clap 2.33 - lazy_static to 1.4.0 - libc to 0.2.66 - proc-macro2 to 1.0.7 - syn to 1.0.5. - winapi 0.3.8
Diffstat (limited to 'openpgp-ffi/Cargo.toml')
-rw-r--r--openpgp-ffi/Cargo.toml6
1 files changed, 3 insertions, 3 deletions
diff --git a/openpgp-ffi/Cargo.toml b/openpgp-ffi/Cargo.toml
index d5dbaf5e..85973bec 100644
--- a/openpgp-ffi/Cargo.toml
+++ b/openpgp-ffi/Cargo.toml
@@ -24,9 +24,9 @@ maintenance = { status = "actively-developed" }
[dependencies]
sequoia-ffi-macros = { path = "../ffi-macros", version = "0.20" }
sequoia-openpgp = { path = "../openpgp", version = "0.20", default-features = false }
-anyhow = "1"
-lazy_static = "1.0.0"
-libc = "0.2.33"
+anyhow = "1.0.5"
+lazy_static = "1.4.0"
+libc = "0.2.66"
memsec = { version = "0.6", default-features = false }
[dev-dependencies]