summaryrefslogtreecommitdiffstats
path: root/openpgp-ffi/Cargo.toml
diff options
context:
space:
mode:
authorJustus Winter <justus@sequoia-pgp.org>2019-03-21 15:24:41 +0100
committerJustus Winter <justus@sequoia-pgp.org>2019-03-21 15:24:41 +0100
commitc0a170a65cdc587c76787c3fc988be77bf4f6675 (patch)
tree5f0c69b1526c0526882758579e19de0a80fbd0b4 /openpgp-ffi/Cargo.toml
parente4998146b6e68360f81c9d44d5e57008613b5f73 (diff)
openpgp-ffi: Use crate for futimes fiddling.
- The previous solution of using libc::futimes turned out to be not portable because different platforms have differently sized timestamps. Use a crate for that instead. - Also, bring ffi's c-tests up-to-speed. - Fixes #225.
Diffstat (limited to 'openpgp-ffi/Cargo.toml')
-rw-r--r--openpgp-ffi/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/openpgp-ffi/Cargo.toml b/openpgp-ffi/Cargo.toml
index 5c9a272a..9cb1d4ef 100644
--- a/openpgp-ffi/Cargo.toml
+++ b/openpgp-ffi/Cargo.toml
@@ -30,6 +30,7 @@ memsec = "0.5.4"
time = "0.1.40"
[dev-dependencies]
+filetime = "0.2"
nettle = "5.0"
[lib]