summaryrefslogtreecommitdiffstats
path: root/openpgp-ffi/Cargo.toml
diff options
context:
space:
mode:
authorJustus Winter <justus@sequoia-pgp.org>2019-01-25 13:25:30 +0100
committerJustus Winter <justus@sequoia-pgp.org>2019-01-25 14:04:26 +0100
commit2a162dcaf165e59b72a24825bdc2e1c627979d23 (patch)
treec37e20eb031a33940baa89b2b823169b6553a511 /openpgp-ffi/Cargo.toml
parent118a86b0302b4bb35b1f1bbef50b2a042f239384 (diff)
ffi-macros: Protect against use-after-free.
- When we transfer ownership from C to Rust, we move the wrapped object out of the wrapper, and poison the wrapper. - This prevents reuse of the wrapper object. When a stale reference is given to us, we check the tag encoding the type information. - If the tag field is poisoned, we can produce a more helpful error message. This is not exact, of course. As soon as the memory is reused, our tag is overwritten.
Diffstat (limited to 'openpgp-ffi/Cargo.toml')
-rw-r--r--openpgp-ffi/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/openpgp-ffi/Cargo.toml b/openpgp-ffi/Cargo.toml
index 1bb6aab1..a719871b 100644
--- a/openpgp-ffi/Cargo.toml
+++ b/openpgp-ffi/Cargo.toml
@@ -26,6 +26,7 @@ sequoia-openpgp = { path = "../openpgp" }
failure = "0.1.2"
lazy_static = "1.0.0"
libc = "0.2.33"
+memsec = "0.5.4"
time = "0.1.40"
[dev-dependencies]