summaryrefslogtreecommitdiffstats
path: root/net/Cargo.toml
diff options
context:
space:
mode:
authoramesgen <amesgen@amesgen.de>2020-10-14 15:38:04 +0200
committerIgor Matuszewski <igor@sequoia-pgp.org>2020-10-23 12:05:54 +0200
commiteb324f60bbd4184057797f72cc3db34e6160497d (patch)
treec5c5438a2640435c419c8ed496693301dede9544 /net/Cargo.toml
parent731f01cf5f3699ab738333a65a541d3fb2f25e15 (diff)
update net to futures=0.2
Diffstat (limited to 'net/Cargo.toml')
-rw-r--r--net/Cargo.toml11
1 files changed, 5 insertions, 6 deletions
diff --git a/net/Cargo.toml b/net/Cargo.toml
index fc0525d8..bb546e3c 100644
--- a/net/Cargo.toml
+++ b/net/Cargo.toml
@@ -25,22 +25,21 @@ sequoia-openpgp = { path = "../openpgp", version = "0.20", default-features = fa
sequoia-core = { path = "../core", version = "0.20" }
anyhow = "1"
-futures = "0.1"
-http = "0.1.5"
-hyper = "0.12"
-hyper-tls = "0.3"
+futures-util = "0.3"
+http = "0.2"
+hyper = "0.13"
+hyper-tls = "0.4"
libc = "0.2.33"
native-tls = "0.2.0"
percent-encoding = "2.1"
tempfile = "3.1"
thiserror = "1"
-tokio-core = "0.1"
-tokio-io = "0.1.4"
url = "2.1"
zbase32 = "0.1.2"
[dev-dependencies]
rand = { version = "0.7", default-features = false }
+tokio = { version = "0.2", features = ["full"] }
[features]
default = ["compression"]