summaryrefslogtreecommitdiffstats
path: root/net/Cargo.toml
diff options
context:
space:
mode:
authorJustus Winter <justus@sequoia-pgp.org>2020-03-09 11:42:45 +0100
committerJustus Winter <justus@sequoia-pgp.org>2020-03-09 18:09:50 +0100
commit391a4b92c977cd64dfd131f3e29b0bc8d756d064 (patch)
treeb5b96ff935853cef9ee22e01890c248a791e724e /net/Cargo.toml
parent58d662c6d37dd1b0dccd4d0ce30290b8ede408e9 (diff)
Switch from failure to anyhow.
- Use the anyhow crate instead of failure to implement the dynamic side of our error handling. anyhow::Error derefs to dyn std::error::Error, allowing better interoperability with other stdlib-based error handling libraries. - Fixes #444.
Diffstat (limited to 'net/Cargo.toml')
-rw-r--r--net/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/net/Cargo.toml b/net/Cargo.toml
index f817a6b2..86a4404c 100644
--- a/net/Cargo.toml
+++ b/net/Cargo.toml
@@ -24,7 +24,7 @@ maintenance = { status = "actively-developed" }
sequoia-openpgp = { path = "../openpgp", version = "0.15", default-features = false }
sequoia-core = { path = "../core", version = "0.15" }
-failure = "0.1.2"
+anyhow = "1"
futures = "0.1"
http = "0.1.5"
hyper = "0.12"