summaryrefslogtreecommitdiffstats
path: root/ipc/Cargo.toml
diff options
context:
space:
mode:
authorJustus Winter <justus@sequoia-pgp.org>2019-01-11 15:54:10 +0100
committerJustus Winter <justus@sequoia-pgp.org>2019-05-03 15:20:37 +0200
commit90782208aa073c21fdf6d7e37575f58677c969b5 (patch)
tree0374ccb5b3b0e65f54ef4508fa903270014b3173 /ipc/Cargo.toml
parent4ef67bfa4208f6944edadbf0171958cd3172ea22 (diff)
ipc: New crate.
Diffstat (limited to 'ipc/Cargo.toml')
-rw-r--r--ipc/Cargo.toml32
1 files changed, 32 insertions, 0 deletions
diff --git a/ipc/Cargo.toml b/ipc/Cargo.toml
new file mode 100644
index 00000000..27b9aaa0
--- /dev/null
+++ b/ipc/Cargo.toml
@@ -0,0 +1,32 @@
+[package]
+name = "sequoia-ipc"
+description = "Interprocess communication infrastructure for Sequoia"
+version = "0.6.0"
+authors = [
+ "Justus Winter <justus@sequoia-pgp.org>",
+ "Kai Michaelis <kai@sequoia-pgp.org>",
+ "Neal H. Walfield <neal@sequoia-pgp.org>",
+]
+documentation = "https://docs.sequoia-pgp.org/sequoia_ipc"
+homepage = "https://sequoia-pgp.org/"
+repository = "https://gitlab.com/sequoia-pgp/sequoia"
+readme = "README.md"
+license = "GPL-3.0"
+
+[badges]
+gitlab = { repository = "sequoia-pgp/sequoia" }
+maintenance = { status = "actively-developed" }
+
+[dependencies]
+sequoia-openpgp = { path = "../openpgp" }
+sequoia-core = { path = "../core" }
+
+capnp-rpc = "0.9"
+failure = "0.1.2"
+fs2 = "0.4.2"
+futures = "0.1"
+libc = "0.2.33"
+memsec = "0.5.4"
+rand = "0.6"
+tokio-core = "0.1"
+tokio-io = "0.1.4"