summaryrefslogtreecommitdiffstats
path: root/guide/Cargo.toml
diff options
context:
space:
mode:
authorNora Widdecke <nora@sequoia-pgp.org>2021-01-15 18:19:35 +0100
committerNora Widdecke <nora@sequoia-pgp.org>2021-01-17 19:42:12 +0100
commitd13509a9c4614ba409032fa8115f148ee34356e0 (patch)
tree0a085a0459bf9f10ec07fa1dae685935289b1d5d /guide/Cargo.toml
parent90ab455f357fbc88fe1645250522316bd89554ce (diff)
openpgp: Ignore tests when benchmarking.
- The libtest benchmark harness that is automatically added by cargo interferes with criterion. Disable it everywhere where there are no benchmarks. - https://github.com/rust-lang/rust/issues/47241 - https://bheisler.github.io/criterion.rs/book/faq.html
Diffstat (limited to 'guide/Cargo.toml')
-rw-r--r--guide/Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/guide/Cargo.toml b/guide/Cargo.toml
index 01b02208..713c6143 100644
--- a/guide/Cargo.toml
+++ b/guide/Cargo.toml
@@ -14,3 +14,6 @@ build = "build.rs"
[dependencies]
sequoia-openpgp = { path = "../openpgp", version = "1.0.0" }
anyhow = "1.0.18"
+
+[lib]
+bench = false