summaryrefslogtreecommitdiffstats
path: root/ffi/Cargo.toml
diff options
context:
space:
mode:
authorJustus Winter <justus@sequoia-pgp.org>2018-07-26 14:52:17 +0200
committerJustus Winter <justus@sequoia-pgp.org>2018-07-26 14:59:25 +0200
commit3f6b0c5b303d78e3fa9d6e6206f86f7de93deebb (patch)
tree39636530a7bfbf99b149a56f7c0e2d0df41aa0e7 /ffi/Cargo.toml
parent6ca5eea8136ac5f1a95f2120f1a6e803b1155026 (diff)
ffi: Improve c doctests.
- Wrap code in a main function if none exists. - Derive names for tests not bound to a function. - Honor no-run and ignore. - Fix all examples that are now tests.
Diffstat (limited to 'ffi/Cargo.toml')
-rw-r--r--ffi/Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/ffi/Cargo.toml b/ffi/Cargo.toml
index 5d52f231..c3985550 100644
--- a/ffi/Cargo.toml
+++ b/ffi/Cargo.toml
@@ -13,5 +13,8 @@ lazy_static = "1.0.0"
libc = "0.2.33"
native-tls = "0.2.0"
+[dev-dependencies]
+nettle = { git = "https://gitlab.com/sequoia-pgp/nettle-rs.git" }
+
[lib]
crate-type = ["cdylib", "staticlib"]