summaryrefslogtreecommitdiffstats
path: root/ffi-macros/Cargo.toml
diff options
context:
space:
mode:
authorJustus Winter <justus@sequoia-pgp.org>2019-01-16 13:43:07 +0100
committerJustus Winter <justus@sequoia-pgp.org>2019-01-16 13:52:53 +0100
commit83873fca4714be6ceb264d6d1ca7d56b4fda8150 (patch)
treef3088db6dc878b3413e4657fc828d998784eb1be /ffi-macros/Cargo.toml
parent977fae00f57ca87fa08568a3ce0f55a5382af13a (diff)
ffi-macros: New crate.
- This crate contains macros for Sequoia's FFI crate(s). Having it in a separate crate means that we can share it when we split the FFI crate into two. - More importantly, we need a separate crate if we want to create procedural macros. - As first macro, this patch adds ffi_catch_abort that wraps a function's body in a catch_unwind block, aborting on panics.
Diffstat (limited to 'ffi-macros/Cargo.toml')
-rw-r--r--ffi-macros/Cargo.toml29
1 files changed, 29 insertions, 0 deletions
diff --git a/ffi-macros/Cargo.toml b/ffi-macros/Cargo.toml
new file mode 100644
index 00000000..152ced79
--- /dev/null
+++ b/ffi-macros/Cargo.toml
@@ -0,0 +1,29 @@
+[package]
+name = "sequoia-ffi-macros"
+description = "Macros for writing the C API for Sequoia"
+version = "0.3.0"
+authors = [
+ "Justus Winter <justus@sequoia-pgp.org>",
+ "Kai Michaelis <kai@sequoia-pgp.org>",
+ "Neal H. Walfield <neal@sequoia-pgp.org>",
+]
+documentation = "https://docs.sequoia-pgp.org/sequoia_ffi"
+homepage = "https://sequoia-pgp.org/"
+repository = "https://gitlab.com/sequoia-pgp/sequoia"
+readme = "README.md"
+license = "GPL-3.0"
+
+[badges]
+gitlab = { repository = "sequoia-pgp/sequoia" }
+maintenance = { status = "actively-developed" }
+
+[dependencies]
+proc-macro2 = "0.4"
+quote = "0.6"
+
+[dependencies.syn]
+version = "0.15"
+features = ["full"]
+
+[lib]
+proc-macro = true