summaryrefslogtreecommitdiffstats
path: root/ffi-macros/Cargo.toml
diff options
context:
space:
mode:
authorJustus Winter <justus@sequoia-pgp.org>2019-01-22 17:54:48 +0100
committerJustus Winter <justus@sequoia-pgp.org>2019-01-25 14:04:26 +0100
commit118a86b0302b4bb35b1f1bbef50b2a042f239384 (patch)
treeb447470674dc3aea5bf6c6d32a17ca62d438e125 /ffi-macros/Cargo.toml
parent64a7fa27f669b0dd31319a5ebee6ffd0de410336 (diff)
ffi-macros: Check wrapper types at runtime.
- This change adds a tag to the derived wrapper types that identify the type of the wrapped value. - At runtime, we can verify that references to wrapper objects indeed carry the right tag. - Fixes #166.
Diffstat (limited to 'ffi-macros/Cargo.toml')
-rw-r--r--ffi-macros/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/ffi-macros/Cargo.toml b/ffi-macros/Cargo.toml
index e323b452..e37cab34 100644
--- a/ffi-macros/Cargo.toml
+++ b/ffi-macros/Cargo.toml
@@ -19,6 +19,7 @@ maintenance = { status = "actively-developed" }
[dependencies]
lazy_static = "1.0.0"
+nettle = "2.0"
proc-macro2 = "0.4"
quote = "0.6"