summaryrefslogtreecommitdiffstats
path: root/autocrypt/Cargo.toml
diff options
context:
space:
mode:
authorJustus Winter <justus@sequoia-pgp.org>2020-02-06 17:46:56 +0100
committerJustus Winter <justus@sequoia-pgp.org>2020-02-06 18:01:33 +0100
commit6953b4f9902f5f524e92a15518d0132fb662704a (patch)
treea02b4e656196a674146709ad42f32f4b295dcac3 /autocrypt/Cargo.toml
parent2bd001a81fa53e4f3cbc972f6354c8e3e510d1c7 (diff)
autocrypt: New crate.
- Move the autocrypt-related functionality to a new crate. - Fixes #424.
Diffstat (limited to 'autocrypt/Cargo.toml')
-rw-r--r--autocrypt/Cargo.toml25
1 files changed, 25 insertions, 0 deletions
diff --git a/autocrypt/Cargo.toml b/autocrypt/Cargo.toml
new file mode 100644
index 00000000..dc91fd2f
--- /dev/null
+++ b/autocrypt/Cargo.toml
@@ -0,0 +1,25 @@
+[package]
+name = "sequoia-autocrypt"
+description = "Autocrypt support"
+version = "0.13.0"
+authors = [
+ "Justus Winter <justus@sequoia-pgp.org>",
+ "Kai Michaelis <kai@sequoia-pgp.org>",
+ "Neal H. Walfield <neal@sequoia-pgp.org>",
+]
+documentation = "https://docs.sequoia-pgp.org/0.13.0/sequoia_autocrypt"
+homepage = "https://sequoia-pgp.org/"
+repository = "https://gitlab.com/sequoia-pgp/sequoia"
+readme = "README.md"
+keywords = ["autocrypt", "mua", "opportunistic", "mail", "encryption"]
+categories = ["cryptography", "authentication", "email"]
+license = "GPL-2.0-or-later"
+edition = "2018"
+
+[badges]
+gitlab = { repository = "sequoia-pgp/sequoia" }
+maintenance = { status = "actively-developed" }
+
+[dependencies]
+sequoia-openpgp = { path = "../openpgp", version = "0.13" }
+base64 = "0.10.1"