summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJustus Winter <justus@sequoia-pgp.org>2019-01-16 13:43:07 +0100
committerJustus Winter <justus@sequoia-pgp.org>2019-01-16 13:52:53 +0100
commit83873fca4714be6ceb264d6d1ca7d56b4fda8150 (patch)
treef3088db6dc878b3413e4657fc828d998784eb1be /Cargo.toml
parent977fae00f57ca87fa08568a3ce0f55a5382af13a (diff)
ffi-macros: New crate.
- This crate contains macros for Sequoia's FFI crate(s). Having it in a separate crate means that we can share it when we split the FFI crate into two. - More importantly, we need a separate crate if we want to create procedural macros. - As first macro, this patch adds ffi_catch_abort that wraps a function's body in a catch_unwind block, aborting on panics.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 463d0126..24442b0b 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -26,6 +26,7 @@ buffered-reader = { path = "buffered-reader", version = "0.3.0" }
sequoia-openpgp = { path = "openpgp", version = "0.3.0" }
sequoia-core = { path = "core", version = "0.3.0" }
sequoia-ffi = { path = "ffi", version = "0.3.0" }
+sequoia-ffi-macros = { path = "ffi-macros", version = "0.3.0" }
sequoia-net = { path = "net", version = "0.3.0" }
sequoia-store = { path = "store", version = "0.3.0" }
sequoia-tool = { path = "tool", version = "0.3.0" }