summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJustus Winter <justus@pep-project.org>2017-12-12 17:16:00 +0100
committerJustus Winter <justus@pep-project.org>2017-12-13 13:55:20 +0100
commitc86ad83ae31d44aeab3317e5e05d6d63e428f0e0 (patch)
tree12d1aac77f256e733104e98faf9143152eacd573 /Cargo.toml
parentc0cab61441df7a0334f817c2cc4817a0910e1193 (diff)
Split up Sequoia.
- Split up into six crates: buffered-reader, openpgp, sequoia-core, sequoia-ffi, sequoia-net, and sequoia-store. - Adjust imports accordingly.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml22
1 files changed, 8 insertions, 14 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 43343ed6..87304717 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,25 +3,19 @@ name = "sequoia"
version = "0.1.0"
authors = ["Neal H. Walfield <neal@gnu.org>"]
+[workspace]
+
[dependencies]
-base64 = "0.8.0"
-bzip2 = "0.3.2"
-flate2 = "0.2"
-futures = "0.1"
-hyper = "0.11"
-hyper-tls = "0.1.2"
-libc = "0.2.33"
-native-tls = "0.1.4"
-nom = "3.2.0"
-num = "0.1.40"
-num-derive = "0.1.41"
-percent-encoding = "1.0.1"
-tokio-core = "0.1"
+buffered-reader = { path = "buffered-reader" }
+openpgp = { path = "openpgp" }
+sequoia-core = { path = "core" }
+sequoia-ffi = { path = "ffi" }
+sequoia-net = { path = "net" }
+sequoia-store = { path = "store" }
[lib]
name = "sequoia"
path = "src/lib.rs"
-crate-type = ["lib", "dylib"]
[[bin]]
doc = false