summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJustus Winter <justus@pep-project.org>2017-11-23 14:34:45 +0100
committerJustus Winter <justus@pep-project.org>2017-11-23 14:36:36 +0100
commit9a5725fe55eb5e49cee09712364ac7b7dcefde51 (patch)
tree4f0b3b5e86a02236a06c503e8adcc03fc6fc1d7e /Cargo.toml
parent8cdab3036cfd2111fd3719abc38ab334bc72ebdc (diff)
Add a foreign function interface.
- For now, we keep the ffi in this crate, later on we may want to move it to sequoia-ffi. - Example code how to use the library from C is added as well.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index e39e4914..d59a30e3 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -4,6 +4,7 @@ version = "0.1.0"
authors = ["Neal H. Walfield <neal@gnu.org>"]
[dependencies]
+libc = "0.2.33"
nom = "3.2.0"
num = "0.1.40"
num-derive = "0.1.41"
@@ -13,6 +14,7 @@ bzip2 = "0.3.2"
[lib]
name = "sequoia"
path = "src/lib.rs"
+crate-type = ["lib", "dylib"]
[[bin]]
doc = false