summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorNeal H. Walfield <neal@pep.foundation>2019-08-02 22:52:14 +0200
committerJustus Winter <justus@sequoia-pgp.org>2019-10-25 15:47:22 +0200
commit88a9e12fb413b964c45d8a372381786b2d88cad4 (patch)
treee1e1ab31fd7477468809168b86d0ea80fc4e1a26 /Cargo.toml
parent016c14898bfda1c106b8178cee3fb28dc32baacb (diff)
rfc2822,openpgp: Move rfc2822 crate to be a private mod in openpgp
- The rfc2822 crate doesn't implement all of RFC 2822. Moreover, it includes a number of extensions. This makes rfc2822 a misnomer. - RFC 2822 is actually obsoleted by RFC 5322. This means that if we ever add support for RFC 5322, it will be an even worse misnomer. - Move the whole crate into the openpgp crate. Note: we don't directly export the API; it is only used internally by packet::userid. - Closes #279.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 0 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 45a7b090..da6996f7 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -25,7 +25,6 @@ maintenance = { status = "actively-developed" }
[dependencies]
buffered-reader = { path = "buffered-reader", version = "0.10" }
-sequoia-rfc2822 = { path = "rfc2822", version = "0.10" }
sequoia-openpgp = { path = "openpgp", version = "0.10" }
sequoia-openpgp-ffi = { path = "openpgp-ffi", version = "0.10" }
sequoia-core = { path = "core", version = "0.10" }