summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorIgor Matuszewski <igor@sequoia-pgp.org>2020-10-06 16:15:31 +0200
committerIgor Matuszewski <xanewok@gmail.com>2020-10-06 20:21:56 +0000
commit52ee6a8fa2d326ba93fd4cbcf134a231bc438d95 (patch)
tree121922f47131b9ced2a71ce59b5b5efe459e5933 /Cargo.toml
parentd6e7a4d92008f030ed8108ae62eb97e37c624e0d (diff)
Remove top-level sequoia package
This runs into surprising interactions when trying to build member packages with other than default feature set. See https://gitlab.com/sequoia-pgp/sequoia/-/issues/575 for more info.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml58
1 files changed, 16 insertions, 42 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 1292c2d1..56ae3aa3 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,46 +1,20 @@
-[package]
-name = "sequoia"
-description = "A cool new OpenPGP implementation"
-version = "0.19.0"
-authors = [
- "Justus Winter <justus@sequoia-pgp.org>",
- "Kai Michaelis <kai@sequoia-pgp.org>",
- "Neal H. Walfield <neal@sequoia-pgp.org>",
-]
-documentation = "https://docs.sequoia-pgp.org/0.19.0/"
-homepage = "https://sequoia-pgp.org/"
-repository = "https://gitlab.com/sequoia-pgp/sequoia"
-readme = "README.md"
-keywords = ["cryptography", "openpgp", "pgp", "encryption", "signing"]
-categories = ["cryptography", "authentication", "email"]
-license = "GPL-2.0-or-later"
-edition = "2018"
-
-[badges]
-gitlab = { repository = "sequoia-pgp/sequoia" }
-maintenance = { status = "actively-developed" }
-
[workspace]
-
-[dependencies]
-buffered-reader = { path = "buffered-reader", version = "0.18" }
-sequoia-openpgp = { path = "openpgp", version = "0.19" }
-sequoia-openpgp-ffi = { path = "openpgp-ffi", version = "0.19" }
-sequoia-autocrypt = { path = "autocrypt", version = "0.19" }
-sequoia-core = { path = "core", version = "0.19" }
-sequoia-ffi = { path = "ffi", version = "0.19" }
-sequoia-ffi-macros = { path = "ffi-macros", version = "0.19" }
-sequoia-ipc = { path = "ipc", version = "0.19" }
-sequoia-net = { path = "net", version = "0.19" }
-sequoia-store = { path = "store", version = "0.19" }
-sequoia-tool = { path = "tool", version = "0.19" }
-sequoia-sop = { path = "sop", version = "0.19" }
-sequoia-sqv = { path = "sqv", version = "0.19" }
-sequoia-guide = { path = "guide", version = "0.19" }
-
-[lib]
-name = "sequoia"
-path = "src/lib.rs"
+members = [
+ "autocrypt",
+ "buffered-reader",
+ "core",
+ "ffi",
+ "ffi-macros",
+ "guide",
+ "ipc",
+ "net",
+ "openpgp",
+ "openpgp-ffi",
+ "sop",
+ "sqv",
+ "store",
+ "tool",
+]
[profile.release]
debug = true