summaryrefslogtreecommitdiffstats
path: root/ipfs-api/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'ipfs-api/Cargo.toml')
-rw-r--r--ipfs-api/Cargo.toml14
1 files changed, 8 insertions, 6 deletions
diff --git a/ipfs-api/Cargo.toml b/ipfs-api/Cargo.toml
index c01d5dd..597a42a 100644
--- a/ipfs-api/Cargo.toml
+++ b/ipfs-api/Cargo.toml
@@ -6,7 +6,7 @@ documentation = "https://docs.rs/ipfs-api"
repository = "https://github.com/ferristseng/rust-ipfs-api"
keywords = ["ipfs"]
categories = ["filesystem", "web-programming"]
-version = "0.4.0-alpha.3"
+version = "0.5.0-alpha1"
readme = "../README.md"
license = "MIT OR Apache-2.0"
@@ -15,17 +15,19 @@ travis-ci = { repository = "ferristseng/rust-ipfs-api" }
[dependencies]
bytes = "0.4"
-error-chain = "0.11"
+error-chain = "0.12"
futures = "0.1"
-hyper = "0.11"
-hyper-multipart-rfc7578 = "0.1.0-alpha"
+http = "0.1"
+hyper = "0.12"
+hyper-multipart-rfc7578 = "0.2.0-alpha2"
serde = "1.0"
serde_derive = "1.0"
serde_json = "1.0"
serde_urlencoded = "0.5"
-tokio-core = "0.1"
+tokio = "0.1"
+tokio-codec = "0.1"
tokio-io = "0.1"
[dev-dependencies]
-tokio-timer = "0.1"
+tokio-timer = "0.2"
tar = "0.4"