summaryrefslogtreecommitdiffstats
path: root/ipfs-api/Cargo.toml
diff options
context:
space:
mode:
authorSameer Puri <sameer@users.noreply.github.com>2019-02-09 14:34:00 -0600
committerSameer Puri <sameer@users.noreply.github.com>2019-02-13 18:29:04 -0600
commit4bdebbf4d1d1edb839eba860b013e3fdb870f66e (patch)
tree965a5a80b387c0eb719ca568a96a729d9d3f2ade /ipfs-api/Cargo.toml
parentf125fdbde329095419630e02ebf33d2c73aeced7 (diff)
Add actix feature for using actix-web
Diffstat (limited to 'ipfs-api/Cargo.toml')
-rw-r--r--ipfs-api/Cargo.toml10
1 files changed, 8 insertions, 2 deletions
diff --git a/ipfs-api/Cargo.toml b/ipfs-api/Cargo.toml
index f3fb604..39cad56 100644
--- a/ipfs-api/Cargo.toml
+++ b/ipfs-api/Cargo.toml
@@ -13,13 +13,19 @@ license = "MIT OR Apache-2.0"
[badges]
travis-ci = { repository = "ferristseng/rust-ipfs-api" }
+[features]
+default = ["hyper", "hyper-multipart-rfc7578"]
+actix = ["actix-web", "actix-multipart-rfc7578"]
+
[dependencies]
+actix-multipart-rfc7578 = { version = "0.1", optional = true }
+actix-web = { version = "0.7", optional = true }
bytes = "0.4"
failure = "0.1.2"
futures = "0.1"
http = "0.1"
-hyper = "0.12"
-hyper-multipart-rfc7578 = "0.3.0"
+hyper = { version = "0.12", optional = true }
+hyper-multipart-rfc7578 = { version = "0.3", optional = true }
serde = "1.0"
serde_derive = "1.0"
serde_json = "1.0"