summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index d220b030..09335107 100644
--- a/meson.build
+++ b/meson.build
@@ -69,6 +69,9 @@ deps += [
dependency('libstartup-notification-1.0'),
]
+libgif = c_compiler.find_library('libgif', required: false)
+deps += [ libgif ]
+
check = dependency('check', version: '>= 0.11.0', required: get_option('check'))
header_conf = configuration_data()
@@ -88,6 +91,7 @@ header_conf.set('GLIB_VERSION_MIN_REQUIRED', '(G_ENCODE_VERSION(@0@,@1@))'.forma
header_conf.set('GLIB_VERSION_MAX_ALLOWED', '(G_ENCODE_VERSION(@0@,@1@))'.format(glib_min_major, glib_min_minor))
header_conf.set('ENABLE_DRUN', get_option('drun'))
+header_conf.set('HAVE_LIBGIF', libgif.found())
header_conf.set('WINDOW_MODE', get_option('window'))
header_conf.set_quoted('MANPAGE_PATH', join_paths(get_option('prefix'), get_option('mandir')))