summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3b430991..53b89c4e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -90,6 +90,9 @@ AC_CHECK_FUNC([fcntl],, AC_MSG_ERROR("Could not find fcntl"))
AC_CHECK_FUNC([setlocale],,AC_MSG_ERROR("Could not find setlocale"))
AC_CHECK_FUNC([atexit],, AC_MSG_ERROR("Could not find atexit in c library"))
+AC_CHECK_HEADER([math.h],, AC_MSG_ERROR("Could not find math.h header file"))
+AC_CHECK_LIB([m],[asin],, AC_MSG_ERROR("Could not find asin in math library"))
+
dnl ---------------------------------------------------------------------
dnl Check dependencies
dnl ---------------------------------------------------------------------