summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am83
1 files changed, 60 insertions, 23 deletions
diff --git a/Makefile.am b/Makefile.am
index 5eb96e3f..32391c49 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,7 +6,6 @@ ACLOCAL_AMFLAGS = -I libgwater ${ACLOCAL_FLAGS}
AM_YFLAGS = -d
noinst_LIBRARIES =
-include $(top_srcdir)/libgwater-xcb-nolibtool.mk
##
# PKG CONFIG file
@@ -59,17 +58,16 @@ SOURCES=\
source/widgets/listview.c\
source/widgets/scrollbar.c\
source/xrmoptions.c\
+ source/xkb.c\
source/x11-helper.c\
source/dialogs/run.c\
source/dialogs/ssh.c\
source/dialogs/drun.c\
source/dialogs/dmenu.c\
source/dialogs/combi.c\
- source/dialogs/window.c\
source/dialogs/script.c\
source/dialogs/help-keys.c\
- include/xcb.h\
- include/xcb-internal.h\
+ include/display.h\
include/rofi.h\
include/mode.h\
include/mode-private.h\
@@ -91,17 +89,38 @@ SOURCES=\
include/widgets/scrollbar.h\
include/xrmoptions.h\
include/x11-helper.h\
+ include/dialogs/window.h\
include/dialogs/ssh.h\
include/dialogs/run.h\
include/dialogs/drun.h\
include/dialogs/dmenu.h\
include/dialogs/combi.h\
include/dialogs/script.h\
- include/dialogs/window.h\
include/dialogs/dialogs.h\
include/dialogs/help-keys.h\
- include/xkb.h\
- include/xkb-internal.h
+ include/xkb-internal.h\
+ include/xkb.h
+
+if WAYLAND_BACKEND
+SOURCES += source/wayland.c include/wayland.h
+nodist_rofi_SOURCES += source/unstable/launcher-menu/launcher-menu-unstable-v1-protocol.c
+include $(top_srcdir)/libgwater-wayland-nolibtool.mk
+if WINDOW_MODE
+SOURCES += source/dialogs/window-wayland.c
+nodist_rofi_SOURCES += source/unstable/window-switcher/window-switcher-unstable-v1-protocol.c
+endif
+
+rofi source/rofi-wayland.o: include/unstable/launcher-menu/launcher-menu-unstable-v1-client-protocol.h
+rofi source/rofi-wayland.o source/dialogs/rofi-window-wayland.o: include/unstable/window-switcher/window-switcher-unstable-v1-client-protocol.h
+endif
+
+if XCB_BACKEND
+SOURCES += source/xcb.c include/xcb.h
+include $(top_srcdir)/libgwater-xcb-nolibtool.mk
+if WINDOW_MODE
+SOURCES += source/dialogs/window-xcb.c
+endif
+endif
rofi_SOURCES=\
lexer/theme-parser.y\
@@ -111,12 +130,14 @@ rofi_SOURCES=\
rofi_CFLAGS=\
$(AM_CFLAGS)\
$(glib_CFLAGS)\
+ $(GW_WAYLAND_CFLAGS)\
$(GW_XCB_CFLAGS)\
+ $(xrm_CFLAGS)\
$(pango_CFLAGS)\
- $(libsn_CFLAGS)\
$(cairo_CFLAGS)\
-DMANPAGE_PATH="\"$(mandir)/\""\
-I$(top_srcdir)/include/\
+ -I$(top_builddir)/include/\
-I$(top_srcdir)/config/\
-I$(top_builddir)/\
-Werror=missing-prototypes\
@@ -126,8 +147,9 @@ rofi_CFLAGS=\
rofi_LDADD=\
$(glib_LIBS)\
+ $(GW_WAYLAND_LIBS)\
$(GW_XCB_LIBS)\
- $(libsn_LIBS)\
+ $(xrm_LIBS)\
$(pango_LIBS)\
$(cairo_LIBS)\
$(LIBS)
@@ -252,9 +274,8 @@ textbox_test_CFLAGS=\
$(AM_CFLAGS)\
$(glib_CFLAGS)\
$(pango_CFLAGS)\
- $(GW_XCB_CFLAGS)\
+ $(GW_WAYLAND_CFLAGS)\
$(cairo_CFLAGS)\
- $(libsn_CFLAGS)\
-I$(top_srcdir)/include/\
-I$(top_srcdir)/config/\
-I$(top_builddir)/
@@ -262,9 +283,8 @@ textbox_test_CFLAGS=\
textbox_test_LDADD=\
$(glib_LIBS)\
$(pango_LIBS)\
- $(GW_XCB_LIBS)\
- $(cairo_LIBS)\
- $(libsn_LIBS)
+ $(GW_WAYLAND_LIBS)\
+ $(cairo_LIBS)
helper_pidfile_CFLAGS=$(textbox_test_CFLAGS)
helper_pidfile_LDADD=$(textbox_test_LDADD)
@@ -277,7 +297,7 @@ helper_pidfile_SOURCES=\
include/helper.h\
include/helper-theme.h\
include/xrmoptions.h\
- source/xrmoptions.c\
+ source/xrmoptions-dummy.c\
source/x11-helper.c\
include/x11-helper.h\
test/helper-pidfile.c
@@ -293,7 +313,7 @@ helper_tokenize_SOURCES=\
include/helper.h\
include/helper-theme.h\
include/xrmoptions.h\
- source/xrmoptions.c\
+ source/xrmoptions-dummy.c\
source/x11-helper.c\
include/x11-helper.h\
test/helper-tokenize.c
@@ -364,7 +384,7 @@ helper_test_SOURCES=\
include/helper.h\
include/helper-theme.h\
include/xrmoptions.h\
- source/xrmoptions.c\
+ source/xrmoptions-dummy.c\
source/x11-helper.c\
test/helper-test.c
@@ -372,9 +392,8 @@ helper_test_CFLAGS=\
$(AM_CFLAGS)\
$(glib_CFLAGS)\
$(pango_CFLAGS)\
- $(GW_XCB_CFLAGS)\
+ $(GW_WAYLAND_CFLAGS)\
$(cairo_CFLAGS)\
- $(libsn_CFLAGS)\
-I$(top_srcdir)/include/\
-I$(top_srcdir)/config/\
-I$(top_builddir)/
@@ -382,8 +401,7 @@ helper_test_CFLAGS=\
helper_test_LDADD=\
$(glib_LIBS)\
$(pango_LIBS)\
- $(GW_XCB_LIBS)\
- $(libsn_LIBS)\
+ $(GW_WAYLAND_LIBS)\
$(cairo_LIBS)
helper_expand_SOURCES=\
@@ -395,7 +413,7 @@ helper_expand_SOURCES=\
include/helper.h\
include/helper-theme.h\
include/xrmoptions.h\
- source/xrmoptions.c\
+ source/xrmoptions-dummy.c\
source/x11-helper.c\
test/helper-expand.c
@@ -415,7 +433,7 @@ helper_config_cmdline_parser_SOURCES=\
include/helper.h\
include/helper-theme.h\
include/xrmoptions.h\
- source/xrmoptions.c\
+ source/xrmoptions-dummy.c\
source/x11-helper.c\
test/helper-config-cmdline-parser.c
@@ -523,3 +541,22 @@ coverage-clean:
.PHONY: .FORCE
.FORCE:
+
+# Wayland protocol code generation rules
+source/%-protocol.c: $(wpprotocoldir)/%.xml
+ $(AM_V_GEN)$(MKDIR_P) $(dir $@) && $(WAYLAND_SCANNER) code < $< > $@
+
+include/%-server-protocol.h: $(wpprotocoldir)/%.xml
+ $(AM_V_GEN)$(MKDIR_P) $(dir $@) && $(WAYLAND_SCANNER) server-header < $< > $@
+
+include/%-client-protocol.h: $(wpprotocoldir)/%.xml
+ $(AM_V_GEN)$(MKDIR_P) $(dir $@) && $(WAYLAND_SCANNER) client-header < $< > $@
+
+source/%-protocol.c: $(wwprotocoldir)/%.xml
+ $(AM_V_GEN)$(MKDIR_P) $(dir $@) && $(WAYLAND_SCANNER) code < $< > $@
+
+include/%-server-protocol.h: $(wwprotocoldir)/%.xml
+ $(AM_V_GEN)$(MKDIR_P) $(dir $@) && $(WAYLAND_SCANNER) server-header < $< > $@
+
+include/%-client-protocol.h: $(wwprotocoldir)/%.xml
+ $(AM_V_GEN)$(MKDIR_P) $(dir $@) && $(WAYLAND_SCANNER) client-header < $< > $@