summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorQuentin Glidic <sardemff7+git@sardemff7.net>2019-03-26 12:10:09 +0100
committerQuentin Glidic <sardemff7+git@sardemff7.net>2019-03-26 12:10:09 +0100
commit16c77ea3cef5d4c38ec0ad40eea1551682595863 (patch)
treee6cdc0c2b73015bfb881ea7665690110e8e0dd2c /meson.build
parent0657107fd588fda8320d97a8960f7aa75753190e (diff)
meson: Drop enable- prefix for options
This is the preferred way for Meson projects Signed-off-by: Quentin Glidic <sardemff7+git@sardemff7.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index d628f31f..a4461b53 100644
--- a/meson.build
+++ b/meson.build
@@ -58,7 +58,7 @@ deps += [
dependency('libstartup-notification-1.0'),
]
-check = dependency('check', version: '>= 0.11.0', required: get_option('enable-check'))
+check = dependency('check', version: '>= 0.11.0', required: get_option('check'))
header_conf = configuration_data()
header_conf.set_quoted('PACKAGE_NAME', meson.project_name())
@@ -73,9 +73,9 @@ header_conf.set('_GNU_SOURCE', true)
header_conf.set('USE_NK_GIT_VERSION', true)
-header_conf.set('ENABLE_DRUN', get_option('enable-drun'))
-header_conf.set('WINDOW_MODE', get_option('enable-window'))
-header_conf.set('TIMINGS', get_option('enable-timings'))
+header_conf.set('ENABLE_DRUN', get_option('drun'))
+header_conf.set('WINDOW_MODE', get_option('window'))
+header_conf.set('TIMINGS', get_option('timings'))
header_conf.set_quoted('MANPAGE_PATH', join_paths(get_option('prefix'), get_option('mandir')))
header_conf.set_quoted('SYSCONFDIR', join_paths(get_option('prefix'), get_option('sysconfdir')))