summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDave Davenport <qball@gmpclient.org>2017-09-29 18:44:21 +0200
committerDave Davenport <qball@gmpclient.org>2017-09-29 18:44:21 +0200
commit21e2e674129adb7f579b4edfe37bbeb75f936cc4 (patch)
tree35228c9b7e1ef8333f8a1ca0e1e2a55ab06f644b /meson.build
parentebffe5503d1709f00d4d7d85f0db4f8fe1dc4f42 (diff)
Make tokenize test use libcheck.
- Add some tests for negate.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build24
1 files changed, 12 insertions, 12 deletions
diff --git a/meson.build b/meson.build
index bc84a25b..86afce7d 100644
--- a/meson.build
+++ b/meson.build
@@ -286,18 +286,6 @@ test('helper_pidfile test', executable('helper_pidfile.test', [
dependencies: deps,
))
-test('helper_tokenize test', executable('helper_tokenize.test', [
- 'test/helper-tokenize.c',
- ],
- objects: rofi.extract_objects([
- 'config/config.c',
- 'source/helper.c',
- 'source/xrmoptions.c',
- 'source/rofi-types.c',
- ]),
- dependencies: deps,
-))
-
test('widget test', executable('widget.test', [
'test/widget-test.c',
theme_parser,
@@ -433,6 +421,18 @@ if check.found()
]),
dependencies: deps,
))
+ test('helper_tokenize test', executable('helper_tokenize.test', [
+ 'test/helper-tokenize.c',
+ ],
+ objects: rofi.extract_objects([
+ 'config/config.c',
+ 'source/helper.c',
+ 'source/xrmoptions.c',
+ 'source/rofi-types.c',
+ ]),
+ dependencies: deps,
+ ))
+
endif