summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDave Davenport <qball@gmpclient.org>2017-10-15 11:08:15 +0200
committerDave Davenport <qball@gmpclient.org>2017-10-15 11:08:15 +0200
commit2198d43199854e8b4d9b832c7edc66112c90ff8c (patch)
treeb7f03dc540caea549e5d8a0b5b34cf1aa4312514 /meson.build
parent0248a47a7d9b0864b1da633f13eb620fb67a9b84 (diff)
parent1ab3e571eca1768d437246ca6ec09f44432b0e20 (diff)
Merge remote-tracking branch 'origin/master' into next
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build25
1 files changed, 12 insertions, 13 deletions
diff --git a/meson.build b/meson.build
index efb942df..bc84a25b 100644
--- a/meson.build
+++ b/meson.build
@@ -119,7 +119,6 @@ install_headers([
'include/mode.h',
'include/mode-private.h',
'include/helper.h',
- 'include/rofi-types.h',
],
subdir: meson.project_name(),
)
@@ -287,6 +286,18 @@ test('helper_pidfile test', executable('helper_pidfile.test', [
dependencies: deps,
))
+test('helper_tokenize test', executable('helper_tokenize.test', [
+ 'test/helper-tokenize.c',
+ ],
+ objects: rofi.extract_objects([
+ 'config/config.c',
+ 'source/helper.c',
+ 'source/xrmoptions.c',
+ 'source/rofi-types.c',
+ ]),
+ dependencies: deps,
+))
+
test('widget test', executable('widget.test', [
'test/widget-test.c',
theme_parser,
@@ -422,18 +433,6 @@ if check.found()
]),
dependencies: deps,
))
- test('helper_tokenize test', executable('helper_tokenize.test', [
- 'test/helper-tokenize.c',
- ],
- objects: rofi.extract_objects([
- 'config/config.c',
- 'source/helper.c',
- 'source/xrmoptions.c',
- 'source/rofi-types.c',
- ]),
- dependencies: deps,
- ))
-
endif