summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorQC <qball@gmpclient.org>2015-09-20 11:45:28 +0200
committerQC <qball@gmpclient.org>2015-09-20 11:45:28 +0200
commitfc2d65df0c455c1aa3c3d54a79ea8b5e1727cdf4 (patch)
treede608d9935d7d7cfd6519b3e75acdf032c8458df /configure.ac
parent108c16e0d4a8d576a2655daebc022832f4e647db (diff)
Playing with atom
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 4 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 9c997a37..a94eb514 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,21 +33,15 @@ dnl ---------------------------------------------------------------------
dnl Disable window mode
dnl ---------------------------------------------------------------------
-AC_ARG_ENABLE([windowmode],
- AC_HELP_STRING([--disable-windowmode],[Disable window mode]))
+AC_ARG_ENABLE([windowmode], AC_HELP_STRING([--disable-windowmode],[Disable window mode]))
-AS_IF([ test "x$enable_windowmode" != "xno"], [
-AC_DEFINE([WINDOW_MODE],[1],[Enable the window mode])
-])
+AS_IF([ test "x$enable_windowmode" != "xno"], [AC_DEFINE([WINDOW_MODE],[1],[Enable the window mode])])
##
# I3 check
##
-AC_ARG_ENABLE(i3support,
- [AS_HELP_STRING([--disable-i3support], [Disable check for i3 support])])
-AS_IF([test "x$enable_i3support" != xno && test "x$enable_windowmode" != "xno"],[
- AC_CHECK_HEADERS([i3/ipc.h], [i3_header=yes; break;])
-])
+AC_ARG_ENABLE(i3support, [AS_HELP_STRING([--disable-i3support], [Disable check for i3 support])])
+AS_IF([test "x$enable_i3support" != xno && test "x$enable_windowmode" != "xno"],[AC_CHECK_HEADERS([i3/ipc.h], [i3_header=yes; break;])])
##
# Check dependencies