summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDave Davenport <qball@gmpclient.org>2015-11-14 13:47:45 +0100
committerDave Davenport <qball@gmpclient.org>2015-11-14 13:47:45 +0100
commit80e873c8a31489c33cb62c7932797005adc201d3 (patch)
tree9f957d8dd5de12562bf8d7b16d43f2a0240cd050 /configure.ac
parent45c8de9387cd73a7369c21fcec70ca77e6832076 (diff)
Add threadpool support, add optional timings compile flag
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac45
1 files changed, 27 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index b9ca532d..e2bd2156 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,15 +3,15 @@ AC_INIT([rofi], [0.15.12-devel], [https://github.com/DaveDavenport/rofi/])
AC_CONFIG_SRCDIR([source/rofi.c])
AC_CONFIG_HEADER([config.h])
-##
-# Setup automake to be silent and in foreign mode.
-##
+dnl ---------------------------------------------------------------------
+dnl Setup automake to be silent and in foreign mode.
+dnl ---------------------------------------------------------------------
AM_INIT_AUTOMAKE([-Wall -Werror foreign subdir-objects dist-xz])
AM_SILENT_RULES([yes])
-##
-# Check for compiler
-##
+dnl ---------------------------------------------------------------------
+dnl Check for compiler
+dnl ---------------------------------------------------------------------
AC_PROG_CC([clang gcc cc])
AC_PROG_CC_C99
AM_PROG_CC_C_O
@@ -21,27 +21,31 @@ AC_USE_SYSTEM_EXTENSIONS
dnl ---------------------------------------------------------------------
dnl Disable window mode
dnl ---------------------------------------------------------------------
-
AC_ARG_ENABLE([windowmode], AC_HELP_STRING([--disable-windowmode],[Disable window mode]))
-
AS_IF([ test "x$enable_windowmode" != "xno"], [AC_DEFINE([WINDOW_MODE],[1],[Enable the window mode])])
-##
-# I3 check
-##
+dnl ---------------------------------------------------------------------
+dnl Output timing information
+dnl ---------------------------------------------------------------------
+AC_ARG_ENABLE([timings], AC_HELP_STRING([--enable-timings],[Enable timing output]))
+AS_IF( [ test "x$enable_timings" = "xyes"], [AC_DEFINE([TIMINGS],[1], [Enable timings output])])
+
+dnl ---------------------------------------------------------------------
+dnl I3 check
+dnl ---------------------------------------------------------------------
AC_ARG_ENABLE(i3support, [AS_HELP_STRING([--disable-i3support], [Disable check for i3 support])])
AS_IF([test "x$enable_i3support" != xno && test "x$enable_windowmode" != "xno"],[AC_CHECK_HEADERS([i3/ipc.h], [i3_header=yes; break;])])
-##
-# Check for C functions.
-##
-
+dnl ---------------------------------------------------------------------
+dnl Check for C functions.
+dnl ---------------------------------------------------------------------
AC_CHECK_FUNC([getdelim],, AC_MSG_ERROR("Could not find getdelim in c library"))
AC_CHECK_FUNC([sysconf],, AC_MSG_ERROR("Could not find sysconf"))
-##
-# Check dependencies
-##
+
+dnl ---------------------------------------------------------------------
+dnl Check dependencies
+dnl ---------------------------------------------------------------------
PKG_PROG_PKG_CONFIG
PKG_CHECK_MODULES([x11], [x11])
@@ -66,6 +70,11 @@ echo "I3 support: Enabled"
else
echo "I3 support: Disabled"
fi
+if test x$enable_timings = xyes; then
+echo "Timing output: Enabled"
+else
+echo "Timing output: Disabled"
+fi
echo "-------------------------------------"
echo "Now type 'make' to build"
echo ""