summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorQuentin Glidic <sardemff7+git@sardemff7.net>2016-02-16 11:12:58 +0100
committerDave Davenport <qball@gmpclient.org>2016-02-21 12:42:28 +0100
commit4c11da91f55a5e5922b0d1a537f2e086320a7d4a (patch)
tree7f0aa793e1d5891787f1b5612b9e8ead1d382a78 /configure.ac
parent591429fb58e231580cf793b7719dac7c352fd4d0 (diff)
Autotools cleanup
Signed-off-by: Quentin Glidic <sardemff7+git@sardemff7.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index d1d0b7ce..0fa89fd6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -31,12 +31,17 @@ dnl ---------------------------------------------------------------------
AC_USE_SYSTEM_EXTENSIONS
dnl ---------------------------------------------------------------------
+dnl Base CFLAGS
+dnl ---------------------------------------------------------------------
+AM_CFLAGS="-Wall -Wextra -Wparentheses -Winline -pedantic"
+
+dnl ---------------------------------------------------------------------
dnl Enable source code coverage reporting for GCC
dnl ---------------------------------------------------------------------
AC_ARG_ENABLE(gcov,
[ --enable-gcov Enable source code coverage testing using gcov],
- [CFLAGS="$CFLAGS -coverage"])
+ [AM_CFLAGS="${AM_CFLAGS} -coverage"])
dnl ---------------------------------------------------------------------
dnl Disable window mode
dnl ---------------------------------------------------------------------
@@ -82,7 +87,7 @@ PKG_CHECK_MODULES([libsn], [libstartup-notification-1.0])
dnl ---------------------------------------------------------------------
dnl Add extra compiler flags
dnl ---------------------------------------------------------------------
-AC_SUBST([EXTRA_CFLAGS], ["-Wall -Wextra -Wparentheses -Winline -pedantic"])
+AC_SUBST([AM_CFLAGS])
AC_CONFIG_FILES([Makefile doc/rofi.doxy])
AC_OUTPUT