summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDave Davenport <qball@gmpclient.org>2015-12-31 19:09:25 +0100
committerDave Davenport <qball@gmpclient.org>2015-12-31 19:09:25 +0100
commit306029976f6526c2efd43689c5b0ef202e05af52 (patch)
treea246f31076af9335f5c5307c46d95afa9d70226d /configure.ac
parent192acf0f7871fab9b3bd321910c13ebeba96f4e3 (diff)
Add coverage flag
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 32b1f49f..a5d4a7a1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -31,6 +31,13 @@ dnl ---------------------------------------------------------------------
AC_USE_SYSTEM_EXTENSIONS
dnl ---------------------------------------------------------------------
+dnl Enable source code coverage reporting for GCC
+dnl ---------------------------------------------------------------------
+
+AC_ARG_ENABLE(gcov,
+ [ --enable-gcov Enable source code coverage testing using gcov],
+ [CFLAGS="$CFLAGS -coverage"])
+dnl ---------------------------------------------------------------------
dnl Disable window mode
dnl ---------------------------------------------------------------------
AC_ARG_ENABLE([windowmode], AC_HELP_STRING([--disable-windowmode],[Disable window mode]))