summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDave Davenport <qball@gmpclient.org>2019-01-07 17:19:33 +0100
committerDave Davenport <qball@gmpclient.org>2019-01-07 17:21:31 +0100
commitf42cffe96201b1e5886e5069856a02eeb3bf5733 (patch)
treed25b6bcf356b08d11b5a0fa46866e62c183dce30 /configure.ac
parent9465d189f730a6a6ada3cb7bdc0660607b645fb6 (diff)
Return EX_DATAERR when fails to parse theme.
This way a script can check if there was an error, otherwise you can wind up in a loop.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d404b48b..7ab3d273 100644
--- a/configure.ac
+++ b/configure.ac
@@ -109,6 +109,8 @@ AC_CHECK_HEADER([math.h],, AC_MSG_ERROR("Could not find math.h header file"))
AC_SEARCH_LIBS([floor],[m],, AC_MSG_ERROR("Could not find floor in math library"))
AC_SEARCH_LIBS([ceil], [m],, AC_MSG_ERROR("Could not find ceil in math library"))
+AC_CHECK_HEADER([sysexits.h],, AC_MSG_ERROR("Could not find the sysexists.h header file"))
+
dnl ---------------------------------------------------------------------
dnl Check dependencies
dnl ---------------------------------------------------------------------