summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDave Davenport <qball@gmpclient.org>2019-07-06 11:32:37 +0200
committerDave Davenport <qball@gmpclient.org>2019-07-06 11:32:37 +0200
commitaa9970fa2a33439effbf7709d96b508810bf043a (patch)
tree1c3dc2bb70f8be3564bced4a52de37ba0a9b1bdb /configure.ac
parentbe21fbae5d11916619f1b259a4b2191fcb19dae8 (diff)
[build] Check for the strchrnul function in configure.ac
Issue: #989
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b4dfbc1c..4df3961f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -99,6 +99,7 @@ AC_CHECK_FUNC([fcntl],, AC_MSG_ERROR("Could not find fcntl"))
AC_CHECK_FUNC([setlocale],,AC_MSG_ERROR("Could not find setlocale"))
AC_CHECK_FUNC([atexit],, AC_MSG_ERROR("Could not find atexit in c library"))
AC_CHECK_FUNC([glob],, AC_MSG_ERROR("Could not find glob in c library"))
+AC_CHECK_FUNC([strchrnul],,AC_MSG_ERROR("Could not find strchrnul function in c library (gnu extension)"))
AC_CHECK_HEADER([math.h],, AC_MSG_ERROR("Could not find math.h header file"))
AC_SEARCH_LIBS([floor],[m],, AC_MSG_ERROR("Could not find floor in math library"))