summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDave Davenport <qball@gmpclient.org>2016-09-26 11:56:20 +0200
committerDave Davenport <qball@gmpclient.org>2016-09-26 11:57:40 +0200
commit5815dc7b75d80dfd9424d39a42758161587e28b2 (patch)
treedd8cb788a8d205dc14537556b8ee67b54feb8aa3 /configure.ac
parentca766b4ed7e1d195825b183f48452ad4d6e83918 (diff)
Issue #474: reverse logic.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 2a0d444e..16ba46bb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -57,8 +57,8 @@ AC_ARG_ENABLE(asan,
dnl --------------------------------------------------------------------
dnl DRun dialog
dnl --------------------------------------------------------------------
-AC_ARG_ENABLE([drun], AC_HELP_STRING([--enable-drun],[Enable desktop file run dialog]))
-AS_IF([test "x${enable_drun}" == "xyes"], [AC_DEFINE([ENABLE_DRUN], [1], [Enable desktop file run dialog])])
+AC_ARG_ENABLE([drun], AC_HELP_STRING([--disable-drun],[Disable desktop file run dialog]))
+AS_IF([test "x${enable_drun}" != "xno"], [AC_DEFINE([ENABLE_DRUN], [1], [Enable desktop file run dialog])])
dnl ---------------------------------------------------------------------
dnl Disable window mode
dnl ---------------------------------------------------------------------
@@ -119,10 +119,10 @@ echo "Timing output: Enabled"
else
echo "Timing output: Disabled"
fi
-if test x$enable_drun = xyes; then
-echo "Desktop File run dialog Enabled"
+if test x$enable_drun != xno; then
+echo "Desktop File drun dialog Enabled"
else
-echo "Desktop File run dialog Disabled"
+echo "Desktop File drun dialog Disabled"
fi
if test x$enable_windowmode != xno; then
echo "Window Switcher dialog Enabled"