summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDave Davenport <qball@gmpclient.org>2017-02-23 21:55:37 +0100
committerDave Davenport <qball@gmpclient.org>2017-02-23 21:55:37 +0100
commit836a40f0a59d3b919214aad34ac0f5229c883ec4 (patch)
tree6b97afd09ee3d909aca7b60b31f2e5075816acbb /configure.ac
parentb943bb06150a05a773ec6318ff8f7db912d8cdae (diff)
Check flex and bison are found in configure.ac
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1c1d76a2..4df900d9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,10 +3,12 @@ AC_INIT([rofi], [1.3.1], [https://github.com/DaveDavenport/rofi/],[],[https://fo
AC_CONFIG_SRCDIR([source/rofi.c])
AC_CONFIG_HEADER([config.h])
-
AC_PROG_LEX
AC_PROG_YACC
+AS_IF([test "x${LEX}" != "xflex" ], [AC_MSG_ERROR( "Failed to find flex")])
+AS_IF([test "x${YACC}" != "xbison -y" ], [AC_MSG_ERROR( "Failed to find bison")])
+
dnl ---------------------------------------------------------------------
dnl Setup automake to be silent and in foreign mode.
dnl We want xz distribution