summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDave Davenport <qball@gmpclient.org>2015-02-02 14:49:19 +0100
committerDave Davenport <qball@gmpclient.org>2015-02-02 14:49:19 +0100
commitca876feec6e65bfde27306ae5fdc0750c868aecd (patch)
tree5cb79a733d6f211d7040d7b7573d3a8ab34a0024 /configure.ac
parentd081b3e6f5f7266790a7c4485edef71e00ee9919 (diff)
Put i3 specific interaction code in separate file.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 9c87ce22..605cf875 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,8 +21,13 @@ AC_USE_SYSTEM_EXTENSIONS
##
# I3 check
##
-AC_CHECK_HEADERS([i3/ipc.h],
- [i3_header=yes; break;])
+AC_ARG_ENABLE(i3support,
+ [AS_HELP_STRING([--disable-i3support], [Disable check for i3 support])])
+if test "x$enable_i3support" != xno;
+then
+ AC_CHECK_HEADERS([i3/ipc.h],
+ [i3_header=yes; break;])
+fi
dnl ---------------------------------------------------------------------