summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorQball Cow <qball@gmpclient.org>2014-03-17 23:57:49 +0100
committerQball Cow <qball@gmpclient.org>2014-03-17 23:58:08 +0100
commit89b48fb767e5146867781441d8e7fa82ca383851 (patch)
tree81b8f3ab8df1b7db01fad26b4cbdc01b12c60187 /configure.ac
parent7e12aeb5975f8e1ecb191eb770a86e281463e8af (diff)
Fix timeout, detect i3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 84f222b3..3fe964ed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10,6 +10,19 @@ AC_PROG_CC_STDC
AM_PROG_CC_C_O
##
+# I3 check
+##
+AC_CHECK_HEADERS([i3/ipc.h],
+ [i3_header=yes; break;])
+
+AS_IF([test "x$i3_header" != xno],
+ [
+ AM_CONDITIONAL(I3, true)
+ AC_DEFINE(I3, [], [Support for I3])
+ ], [
+ AM_CONDITIONAL(I3, false)
+ ])
+##
# Check dependencies
##
PKG_PROG_PKG_CONFIG