summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDave Davenport <qball@gmpclient.org>2014-11-06 17:21:55 +0100
committerDave Davenport <qball@gmpclient.org>2014-11-06 17:21:55 +0100
commit8046fbec0831b13513e5924acc0519dd6216348d (patch)
tree00643652d03a6d6bddec0d40ec9cce4cc90768ae /configure.ac
parentc549c4f72d1c45049279b76272bba354e88d51a4 (diff)
Allow enabling of debug data from build system.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f6db2a7e..69411321 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,6 +33,15 @@ AC_ARG_ENABLE(gcov,
[ --enable-gcov Enable source code coverage testing using gcov],
[CFLAGS="$CFLAGS -fprofile-arcs -ftest-coverage"])
+
+dnl
+dnl Enable timing debug output.
+dnl
+
+AC_ARG_ENABLE(timings,
+ [ --enable-timings Enable debug information about timings],
+ [CFLAGS="$CFLAGS -DTIMING"])
+
##
# Check dependencies
##