summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDave Davenport <qball@gmpclient.org>2015-09-14 17:51:59 +0200
committerDave Davenport <qball@gmpclient.org>2015-09-14 17:51:59 +0200
commit6a8a367cbdb33cf3ed08ab9813c80d9ad258384a (patch)
tree2228d8b212f0f00236427bc37e7acbdf60c46d33 /configure.ac
parenta645da701fc85d588223667446f688b7fad846ae (diff)
Disable i3 support when window mode disabled.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 9 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index a7790e79..b605522a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -18,16 +18,6 @@ AM_PROG_CC_C_O
AC_USE_SYSTEM_EXTENSIONS
-##
-# I3 check
-##
-AC_ARG_ENABLE(i3support,
- [AS_HELP_STRING([--disable-i3support], [Disable check for i3 support])])
-if test "x$enable_i3support" != xno;
-then
- AC_CHECK_HEADERS([i3/ipc.h],
- [i3_header=yes; break;])
-fi
dnl ---------------------------------------------------------------------
@@ -51,6 +41,15 @@ AC_DEFINE([WINDOW_MODE],[1],[Enable the window mode])
])
##
+# I3 check
+##
+AC_ARG_ENABLE(i3support,
+ [AS_HELP_STRING([--disable-i3support], [Disable check for i3 support])])
+AS_IF([test "x$enable_i3support" != xno && test "x$enable_windowmode" != "xno"],[
+ AC_CHECK_HEADERS([i3/ipc.h], [i3_header=yes; break;])
+])
+
+##
# Check dependencies
##
PKG_PROG_PKG_CONFIG