summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorQC <qball@gmpclient.org>2014-08-29 00:01:36 +0200
committerQC <qball@gmpclient.org>2014-08-29 00:01:36 +0200
commit5b017b017b1dfb6d15c70579246b2ffa9aaea763 (patch)
tree02ee7e0edcd67a01b4d1ee4c4726f0394ea281c0 /configure.ac
parent92f518cdf85b71088824242a31c54e67fadcb1ae (diff)
Add gcov option.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9e1a85f4..2d261341 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,6 +24,15 @@ AC_USE_SYSTEM_EXTENSIONS
AC_CHECK_HEADERS([i3/ipc.h],
[i3_header=yes; break;])
+
+dnl ---------------------------------------------------------------------
+dnl Enable source code coverage reporting for GCC
+dnl ---------------------------------------------------------------------
+
+AC_ARG_ENABLE(gcov,
+ [ --enable-gcov Enable source code coverage testing using gcov],
+ [CFLAGS="$CFLAGS -fprofile-arcs -ftest-coverage"])
+
##
# Check dependencies
##