summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDave Davenport <qball@gmpclient.org>2016-10-21 18:48:01 +0200
committerDave Davenport <qball@gmpclient.org>2016-10-21 18:48:01 +0200
commitf602ea1486ef4d35d431ccda12bbe54e118f3318 (patch)
treea771516d46da7bd8e6db2717b29e7d74e1261d6d /Makefile.am
parenta0637156524aac8c8e66c185e1fa36831ba76cb5 (diff)
Add some tests for the box widget.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 85cc87be..b63b1b15 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -151,7 +151,8 @@ check_PROGRAMS=\
helper_pidfile\
helper_tokenize\
helper_config_cmdline_parser\
- widget_test
+ widget_test\
+ box_test
history_test_CFLAGS=\
@@ -229,6 +230,13 @@ widget_test_CFLAGS=$(textbox_test_CFLAGS)
widget_test_SOURCES=\
source/widgets/widget.c\
test/widget-test.c
+
+box_test_LDADD=$(textbox_test_LDADD)
+box_test_CFLAGS=$(textbox_test_CFLAGS)
+box_test_SOURCES=\
+ source/widgets/widget.c\
+ source/widgets/box.c\
+ test/box-test.c
textbox_test_SOURCES=\
source/widgets/widget.c\
source/widgets/textbox.c\
@@ -314,7 +322,8 @@ TESTS=\
helper_tokenize\
helper_config_cmdline_parser\
textbox_test\
- widget_test
+ widget_test\
+ box_test
.PHONY: test-x
test-x: $(bin_PROGRAMS)