summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDave Davenport <qball@gmpclient.org>2016-03-01 18:11:55 +0100
committerDave Davenport <qball@gmpclient.org>2016-03-01 18:11:55 +0100
commit7d046a1f5bcc3a55f250aed0cbfaf8a54a8d6875 (patch)
treede42f664183bf2bb6c474c13bb4404ad6a181a09 /Makefile.am
parentfb2c23a429d0206043069ca1f571b49d7cbc275f (diff)
Pack magic externs into a xcb_stuff.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 880c511d..148e2e2b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -35,6 +35,8 @@ rofi_SOURCES=\
source/dialogs/combi.c\
source/dialogs/window.c\
source/dialogs/script.c\
+ include/xcb.h\
+ include/xcb-internal.h\
include/rofi.h\
include/mode.h\
include/mode-private.h\
@@ -147,6 +149,7 @@ check_PROGRAMS=rofi_test textbox_test helper_test
rofi_test_CFLAGS=\
$(AM_CFLAGS)\
$(glib_CFLAGS)\
+ $(libsn_CFLAGS)\
-I$(top_srcdir)/include/\
-I$(top_srcdir)/config/\
-I$(top_builddir)/
@@ -173,6 +176,7 @@ textbox_test_CFLAGS=\
$(xinerama_CFLAGS)\
$(GW_XCB_CFLAGS)\
$(cairo_CFLAGS)\
+ $(libsn_CFLAGS)\
-I$(top_srcdir)/include/\
-I$(top_srcdir)/config/\
-I$(top_builddir)/
@@ -183,7 +187,8 @@ textbox_test_LDADD=\
$(x11_LIBS)\
$(xinerama_LIBS)\
$(GW_XCB_LIBS)\
- $(cairo_LIBS)
+ $(cairo_LIBS)\
+ $(libsn_LIBS)
textbox_test_SOURCES=\
source/widget.c\
@@ -221,6 +226,7 @@ helper_test_CFLAGS=\
$(xinerama_CFLAGS)\
$(GW_XCB_CFLAGS)\
$(cairo_CFLAGS)\
+ $(libsn_CFLAGS)\
-I$(top_srcdir)/include/\
-I$(top_srcdir)/config/\
-I$(top_builddir)/