summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDave Davenport <qball@gmpclient.org>2017-04-30 20:03:31 +0200
committerDave Davenport <qball@gmpclient.org>2017-04-30 20:03:31 +0200
commit5d41d228f009f82d5b217e596d8a22798d65fc14 (patch)
tree0d1cf8ac287a5449c389d59a4647a6d3596f95ad /Makefile.am
parent8be234121a4184431fe812b31e6fcef94733df8a (diff)
Make explicit flag for enabling/disabling libcheck usage.
Automagic detection is frowned upon: https://wiki.gentoo.org/wiki/Project:Quality_Assurance/Automagic_dependencies
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 3fd8bb98..38b6b80f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -227,7 +227,7 @@ check_PROGRAMS=\
box_test\
scrollbar_test
-if HAVE_CHECK
+if USE_CHECK
check_PROGRAMS+=mode_test theme_parser_test
endif
@@ -366,7 +366,7 @@ textbox_test_SOURCES=\
include/helper-theme.h\
test/textbox-test.c
-if HAVE_CHECK
+if USE_CHECK
theme_parser_test_CFLAGS=${helper_test_CFLAGS} $(check_CFLAGS)
theme_parser_test_LDADD=${helper_test_LDADD} $(check_LIBS)
theme_parser_test_SOURCES=\
@@ -457,7 +457,7 @@ helper_config_cmdline_parser_SOURCES=\
test/helper-config-cmdline-parser.c
-if HAVE_CHECK
+if USE_CHECK
mode_test_CFLAGS=$(textbox_test_CFLAGS) $(check_CFLAGS)
mode_test_LDADD=$(textbox_test_LDADD) $(check_LIBS)
mode_test_SOURCES=\
@@ -484,7 +484,7 @@ TESTS=\
box_test\
scrollbar_test
-if HAVE_CHECK
+if USE_CHECK
TESTS+=theme_parser_test\
mode_test
endif