summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDave Davenport <qball@gmpclient.org>2017-02-17 14:06:31 +0100
committerDave Davenport <qball@gmpclient.org>2017-02-17 14:06:31 +0100
commitdc7e4aa96e5fd6b3efd073d6b1d86606b0545bca (patch)
tree1d7a83f5c1e9e8ace83790c7b428f05161f0ed66 /Makefile.am
parentf7b4bebb9b6188c5eee3d7e76c89f5b6d574f98d (diff)
Install some headers for use in plugins
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 508244b0..92c997fa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,6 +20,12 @@ BUILT_SOURCES=\
lexer/theme-parser.c\
lexer/theme-lexer.c
+rofiincludedir=${includedir}/rofi
+rofiinclude_HEADERS=\
+ include/mode.h\
+ include/mode-private.h\
+ include/settings.h\
+ include/helper.h
##
# Rofi the program
@@ -69,6 +75,7 @@ SOURCES=\
include/view.h\
include/view-internal.h\
include/helper.h\
+ include/helper-theme.h\
include/timings.h\
include/history.h\
include/theme.h\
@@ -260,6 +267,7 @@ helper_pidfile_SOURCES=\
include/mode-private.h\
source/helper.c\
include/helper.h\
+ include/helper-theme.h\
include/xrmoptions.h\
source/xrmoptions.c\
source/x11-helper.c\
@@ -275,6 +283,7 @@ helper_tokenize_SOURCES=\
include/mode-private.h\
source/helper.c\
include/helper.h\
+ include/helper-theme.h\
include/xrmoptions.h\
source/xrmoptions.c\
source/x11-helper.c\
@@ -335,6 +344,7 @@ textbox_test_SOURCES=\
include/widgets/textbox.h\
include/xrmoptions.h\
include/helper.h\
+ include/helper-theme.h\
test/textbox-test.c
helper_test_SOURCES=\
@@ -344,6 +354,7 @@ helper_test_SOURCES=\
include/mode-private.h\
source/helper.c\
include/helper.h\
+ include/helper-theme.h\
include/xrmoptions.h\
source/xrmoptions.c\
source/x11-helper.c\
@@ -374,6 +385,7 @@ helper_expand_SOURCES=\
include/mode-private.h\
source/helper.c\
include/helper.h\
+ include/helper-theme.h\
include/xrmoptions.h\
source/xrmoptions.c\
source/x11-helper.c\
@@ -393,6 +405,7 @@ helper_config_cmdline_parser_SOURCES=\
include/mode-private.h\
source/helper.c\
include/helper.h\
+ include/helper-theme.h\
include/xrmoptions.h\
source/xrmoptions.c\
source/x11-helper.c\